Egrades Authentication Issues
Incident Report for Information Technology Services
Resolved
A code update has been applied to the eGrades application (site) and is now accepting logins.
Posted Oct 30, 2018 - 11:01 PDT
Identified
Engineers are correcting a login issue with eGrades that began after a schedule update around 9:00 AM this morning.
Posted Oct 30, 2018 - 10:49 PDT